読者です 読者をやめる 読者になる 読者になる

情弱ログ

参考にならないので当てにしないでください

emerge時のdependency conflict例①

# emerge -pvuDN @world

とかしたらこんな感じのconflictが起きた。

 

x11-base/xorg-server:0

(x11-base/xorg-server-1.15.99.902-r2:0/1.15.99.902::gentoo, ebuild scheduled for merge) conflicts with
x11-base/xorg-server:0/1.15.1= required by (x11-drivers/xf86-input-mouse-1.9.0:0/0::gentoo, installed)
<x11-base/xorg-server-1.15.99 required by (x11-drivers/nvidia-drivers-337.19:0/0::gentoo, installed)
x11-base/xorg-server:0/1.15.1= required by (x11-drivers/xf86-input-evdev-2.8.4:0/0::gentoo, installed)
x11-base/xorg-server:0/1.15.1= required by (x11-drivers/xf86-input-keyboard-1.7.0:0/0::gentoo, installed)

 

dev-libs/boost:0

(dev-libs/boost-1.55.0-r1:0/1.55.0::gentoo, ebuild scheduled for merge) conflicts with
>=dev-libs/boost-1.46:0/1.52= required by (app-office/libreoffice-bin-4.2.3.3-r1:0/0::gentoo, installed)
>=dev-libs/boost-1.51.0:0/1.52= required by (dev-libs/liborcus-0.5.1:0/0.5::gentoo, installed)
dev-libs/boost:0/1.52 required by (app-office/libreoffice-bin-4.2.3.3-r1:0/0::gentoo, installed)
dev-libs/boost:0/1.52= required by (dev-cpp/libcmis-0.4.1:0.4/0.4::gentoo, installed)
dev-libs/boost:0/1.52= required by (app-text/libetonyek-0.0.3:0/0::gentoo, installed)
dev-libs/boost:0/1.52= required by (dev-libs/libixion-0.5.0:0/0.5::gentoo, installed)

 

app-office/libreoffice-l10n:0

(app-office/libreoffice-l10n-4.2.4.2:0/0::gentoo, ebuild scheduled for merge) conflicts with
=app-office/libreoffice-l10n-4.2.3.3* required by (app-office/libreoffice-bin-4.2.3.3-r1:0/0::gentoo, installed)

 

app-text/poppler:0

(app-text/poppler-0.26.1:0/46::gentoo, ebuild scheduled for merge) conflicts with
app-text/poppler:0/44=[cxx,jpeg,lcms,tiff,xpdf-headers(+)] required by (net-print/cups-filters-1.0.53:0/0::gentoo, installed)
>=app-text/poppler-0.16:0/44=[cairo,utils] required by (app-misc/tracker-0.16.4:0/16::gentoo, installed)
>=app-text/poppler-0.12.3-r3:0/44= required by (app-text/texlive-core-2013-r1:0/0::gentoo, installed)
app-text/poppler:0/44 required by (app-office/libreoffice-bin-4.2.3.3-r1:0/0::gentoo, installed)
>=app-text/poppler-0.16:0/44=[xpdf-headers(+),cxx] required by (app-office/libreoffice-bin-4.2.3.3-r1:0/0::gentoo, installed)
>=app-text/poppler-0.24:0/44=[cairo] required by (app-text/evince-3.10.3:0/evd3.4-evv3.3::gentoo, installed)
app-text/poppler:0/44=[xpdf-headers(+)] required by (dev-tex/luatex-0.76.0:0/0::gentoo, installed)

 

抜粋していくと、

x11-base/xorg-server:0

(x11-base/xorg-server-1.15.99.902-r2:0/1.15.99.902::gentoo, ebuild scheduled for merge) conflicts with
x11-base/xorg-server:0/1.15.1= required by (x11-drivers/xf86-input-mouse-1.9.0:0/0::gentoo, installed)
<x11-base/xorg-server-1.15.99 required by (x11-drivers/nvidia-drivers-337.19:0/0::gentoo, installed)
x11-base/xorg-server:0/1.15.1= required by (x11-drivers/xf86-input-evdev-2.8.4:0/0::gentoo, installed)
x11-base/xorg-server:0/1.15.1= required by (x11-drivers/xf86-input-keyboard-1.7.0:0/0::gentoo, installed)

 

は、xorg-serverを1.15.99.902-r2にアップデートしようとしたけれど、nvidia-driversがxorg-server-1.15.99未満までしか対応してないからconflictが発生している模様。対応するまで待つかmaskするしかない。

他のxf86-*は今のバージョンのxorg-server(のスロット0/1.15.1)に依存してるので適当に--oneshot付ければアップデート出来る(と思う)

 

dev-libs/boost:0

(dev-libs/boost-1.55.0-r1:0/1.55.0::gentoo, ebuild scheduled for merge) conflicts with
>=dev-libs/boost-1.46:0/1.52= required by (app-office/libreoffice-bin-4.2.3.3-r1:0/0::gentoo, installed)
>=dev-libs/boost-1.51.0:0/1.52= required by (dev-libs/liborcus-0.5.1:0/0.5::gentoo, installed)
dev-libs/boost:0/1.52 required by (app-office/libreoffice-bin-4.2.3.3-r1:0/0::gentoo, installed)
dev-libs/boost:0/1.52= required by (dev-cpp/libcmis-0.4.1:0.4/0.4::gentoo, installed)
dev-libs/boost:0/1.52= required by (app-text/libetonyek-0.0.3:0/0::gentoo, installed)
dev-libs/boost:0/1.52= required by (dev-libs/libixion-0.5.0:0/0.5::gentoo, installed)

これも--oneshotでおk(ただしlibreoffice-binが他の所で依存してるから解決はしない)

 

app-office/libreoffice-l10n:0

(app-office/libreoffice-l10n-4.2.4.2:0/0::gentoo, ebuild scheduled for merge) conflicts with
=app-office/libreoffice-l10n-4.2.3.3* required by (app-office/libreoffice-bin-4.2.3.3-r1:0/0::gentoo, installed)

 

これはlibreoffice-binがlibreoffice-l10n-4.2.3.3*を必要としているのでどうしようもない。待つかmaskのどっちか。

 

app-text/poppler:0

(app-text/poppler-0.26.1:0/46::gentoo, ebuild scheduled for merge) conflicts with
app-text/poppler:0/44=[cxx,jpeg,lcms,tiff,xpdf-headers(+)] required by (net-print/cups-filters-1.0.53:0/0::gentoo, installed)
>=app-text/poppler-0.16:0/44=[cairo,utils] required by (app-misc/tracker-0.16.4:0/16::gentoo, installed)
>=app-text/poppler-0.12.3-r3:0/44= required by (app-text/texlive-core-2013-r1:0/0::gentoo, installed)
app-text/poppler:0/44 required by (app-office/libreoffice-bin-4.2.3.3-r1:0/0::gentoo, installed)
>=app-text/poppler-0.16:0/44=[xpdf-headers(+),cxx] required by (app-office/libreoffice-bin-4.2.3.3-r1:0/0::gentoo, installed)
>=app-text/poppler-0.24:0/44=[cairo] required by (app-text/evince-3.10.3:0/evd3.4-evv3.3::gentoo, installed)
app-text/poppler:0/44=[xpdf-headers(+)] required by (dev-tex/luatex-0.76.0:0/0::gentoo, installed)

 

--oneshot(以下略)(これも解決はしない)

 

 【解決方法】

nvidia-driversとlibreoffice-binのアップデートを待つ。

(libreofficeに関しては、libreoffice-binを削除してlibreofficeに変更すると解決すると思われる。ただしコンパイルに時間がかかるからやらない)